<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#">
<head profile="http://gmpg.org/xfn/11">


<script>
  (function (w,i,d,g,e,t,s) {w[d] = w[d]||[];t= i.createElement(g);
    t.async=1;t.src=e;s=i.getElementsByTagName(g)[0];s.parentNode.insertBefore(t, s);
  })(window, document, '_gscq','script','//widgets.getsitecontrol.com/37090/script.js');
</script>


<link href='http://fonts.googleapis.com/css?family=PT+Sans+Narrow:400,700' rel='stylesheet' type='text/css'>
<link href='http://fonts.googleapis.com/css?family=Sanchez:400italic,400' rel='stylesheet' type='text/css'>
<link href='http://fonts.googleapis.com/css?family=PT+Sans' rel='stylesheet' type='text/css'>


<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en" />
<meta name="verify-v1" content="7XvBEj6Tw9dyXjHST/9sgRGxGymxFdHIZsM6Ob/xo5E=" />
<meta name="viewport" content="width=device-width, maximum-scale=1.0" />

<title>Beyond Good &amp; Evil 2: The Best Trailer of E3 2017 | STASH MAGAZINE</title>
<link rel="Shortcut Icon" href="http://www.stashmedia.tv/wp-content/themes/default/images/favicon.ico" type="image/x-icon" />

<link rel="stylesheet" href="http://www.stashmedia.tv/wp-content/themes/default/style.css" type="text/css" media="screen" />

<link rel="alternate" type="application/rss+xml" title="STASH RSS Feed" href="http://www.stashmedia.tv/feed/" />
<link rel="alternate" type="application/atom+xml" title="STASH Atom Feed" href="http://www.stashmedia.tv/feed/atom/" />
<link rel="pingback" href="http://www.stashmedia.tv/xmlrpc.php" />


<!-- SEO Ultimate (http://www.seodesignsolutions.com/wordpress-seo/) -->
	<meta name="description" content="the follow up to Ubisoft&#039;s Beyond Good &amp; Evil (actually a prequel) made a surprise appearance at E3 2017 with this potty-mouthed but brilliant clip." />
	<meta name="keywords" content="animation,motion design,visual effects,VFX" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Beyond Good &#038; Evil 2: The Best Trailer of E3 2017" />
	<meta property="og:description" content="the follow up to Ubisoft&#039;s Beyond Good &amp; Evil (actually a prequel) made a surprise appearance at E3 2017 with this potty-mouthed but brilliant clip." />
	<meta property="og:url" content="http://www.stashmedia.tv/good-evil-2-trailer/" />
	<meta property="og:image" content="http://www.stashmedia.tv/wp-content/uploads/2017-06-15_0628.png" />
	<meta property="article:published_time" content="2017-06-15" />
	<meta property="article:modified_time" content="2017-06-15" />
	<meta property="article:author" content="http://www.stashmedia.tv/author/snp/" />
	<meta property="article:tag" content="CG" />
	<meta property="article:tag" content="Character Animation" />
	<meta property="article:tag" content="Featured" />
	<meta property="article:tag" content="Games" />
	<meta property="article:tag" content="Beyond Good &amp; Evil" />
	<meta property="article:tag" content="Michel Ancel" />
	<meta property="article:tag" content="Ubisoft" />
	<meta property="og:site_name" content="STASH" />
	<meta name="twitter:card" content="summary" />

<!-- Code Inserter module -->
<meta name="p:domain_verify" content="96865c95552a4fd987e1635075f54d50"/>
<!-- /Code Inserter module -->

<!-- /SEO Ultimate -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="STASH &raquo; Feed" href="http://www.stashmedia.tv/feed/" />
<link rel="alternate" type="application/rss+xml" title="STASH &raquo; Comments Feed" href="http://www.stashmedia.tv/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="STASH &raquo; Beyond Good &#038; Evil 2: The Best Trailer of E3 2017 Comments Feed" href="http://www.stashmedia.tv/good-evil-2-trailer/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.stashmedia.tv\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css'  href='http://www.stashmedia.tv/wp-includes/css/dashicons.min.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://www.stashmedia.tv/wp-includes/js/thickbox/thickbox.css?ver=4.7.5' type='text/css' media='all' />
<link rel='stylesheet' id='posts-from-category-widget-stylesheet-css'  href='http://www.stashmedia.tv/wp-content/plugins/posts-in-category-widget/style.css?ver=1.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='googlefonts-css'  href='http://fonts.googleapis.com/css?family=Roboto:400&subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='A2A_SHARE_SAVE-css'  href='http://www.stashmedia.tv/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.13' type='text/css' media='all' />
<script type='text/javascript' src='http://www.stashmedia.tv/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.stashmedia.tv/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.stashmedia.tv/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.0'></script>
<link rel='https://api.w.org/' href='http://www.stashmedia.tv/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.stashmedia.tv/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.stashmedia.tv/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Xiaozhu: Pleasing Your Homestay Desires' href='http://www.stashmedia.tv/xiaozhu-pleasing-homestay-desires/' />
<link rel='next' title='&#8220;Rollin&#8217; Wild&#8221; Moves onto French Animals' href='http://www.stashmedia.tv/rollin-wild-takes-french-animals/' />
<meta name="generator" content="WordPress 4.7.5" />
<link rel="canonical" href="http://www.stashmedia.tv/good-evil-2-trailer/" />
<link rel='shortlink' href='http://www.stashmedia.tv/?p=51537' />
<link rel="alternate" type="application/json+oembed" href="http://www.stashmedia.tv/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.stashmedia.tv/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F&#038;format=xml" />

<script type="text/javascript">
var a2a_config=a2a_config||{};a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.templates=a2a_config.templates||{};
</script>
<script type="text/javascript" src="http://static.addtoany.com/menu/page.js" async="async"></script>
<!-- Start Drift By WP-Plugin: Drift -->
<!-- Start of Async Drift Code -->
<script>
!function() {
  var t;
  if (t = window.driftt = window.drift = window.driftt || [], !t.init) return t.invoked ? void (window.console && console.error && console.error("Drift snippet included twice.")) : (t.invoked = !0, 
  t.methods = [ "identify", "config", "track", "reset", "debug", "show", "ping", "page", "hide", "off", "on" ], 
  t.factory = function(e) {
    return function() {
      var n;
      return n = Array.prototype.slice.call(arguments), n.unshift(e), t.push(n), t;
    };
  }, t.methods.forEach(function(e) {
    t[e] = t.factory(e);
  }), t.load = function(t) {
    var e, n, o, i;
    e = 3e5, i = Math.ceil(new Date() / e) * e, o = document.createElement("script"), 
    o.type = "text/javascript", o.async = !0, o.crossorigin = "anonymous", o.src = "https://js.driftt.com/include/" + i + "/" + t + ".js", 
    n = document.getElementsByTagName("script")[0], n.parentNode.insertBefore(o, n);
  });
}();
drift.SNIPPET_VERSION = '0.3.1';
drift.load('3evybvcirig7');
</script>
<!-- End of Async Drift Code --><!-- end: Drift Code. -->
<link href="http://www.stashmedia.tv/wp-content/plugins/ep-social-widget/style.css" type="text/css" rel="stylesheet" media="screen" /><style type="text/css">
#header #title a {
background: url(http://www.stashmedia.tv/wp-content/uploads/2012/11/V8_LOGO-tag.jpg) no-repeat;
}
</style>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #eeeeee; }
</style>
<style>
<!--
#search-6{
float: left;
width: 50%;
margin-top: 13px;
}

#simple-social-icons-2{float:right}
-->


.category-theinbox .postimg_single img{width:100%; height:auto}

.category-theinbox .left_wrap {float: left; width: 640px; margin-top: 9px;}

.category-theinbox #content.top{width:640px}


.category-theinbox .sidebar_right_home{float:right}
</style><link rel="icon" href="http://www.stashmedia.tv/wp-content/uploads/cropped-Stash-Favicon-2017-icon-32x32.png" sizes="32x32" />
<link rel="icon" href="http://www.stashmedia.tv/wp-content/uploads/cropped-Stash-Favicon-2017-icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.stashmedia.tv/wp-content/uploads/cropped-Stash-Favicon-2017-icon-180x180.png" />
<meta name="msapplication-TileImage" content="http://www.stashmedia.tv/wp-content/uploads/cropped-Stash-Favicon-2017-icon-270x270.png" />

<style type="text/css" media="screen">

#container a, #container a:link, #container a:visited, #footerwidgets a, #footerwidgets a:link, #footerwidgets a:visited {
color: #333333;}

#container a:hover, #container a:focus, #container a:active, #footerwidgets a:hover, #footerwidgets a:focus, #footerwidgets a:active {
color: #c7c7c7;}

#container h1 a, #container h2 a, #container h3 a, #container h4 a, #container h5 a, #container h6 a,
#container h1 a:link, #container h2 a:link, #container h3 a:link, #container h4 a:link, #container h5 a:link, #container h6 a:link,
#container h1 a:visited, #container h2 a:visited, #container h3 a:visited, #container h4 a:visited, #container h5 a:visited, #container h6 a:visited {
color: #4d4d4d;}

#container h1 a:hover, #container h2 a:hover, #container h3 a:hover, #container h4 a:hover, #container h5 a:hover, #container h6 a:hover,
#container h1 a:focus, #container h2 a:focus, #container h3 a:focus, #container h4 a:focus, #container h5 a:focus, #container h6 a:focus,
#container h1 a:active, #container h2 a:active, #container h3 a:active, #container h4 a:active, #container h5 a:active, #container h6 a:active {
color: #d4d4d4;}

#container a:hover, #container a:focus, #container a:active, #sidebar ul.menu li a:hover, #sidebar_left ul.menu li ul.sub-menu li a:hover, #sidebar_right ul.menu li ul.sub-menu li a:hover, #commentform #submit:hover, #submit:hover, #searchsubmit:hover, .reply a:hover, #prevLink p a:hover, #prevLink p a:focus, #prevLink p a:active, #nextLink p a:hover, #nextLink p a:focus, #nextLink p a:active, #container .portfolioimg a img:hover, #footerwidgets a:hover, #footerwidgets a:focus, #footerwidgets a:active {
background-color: #f0f0f0 !important;}
</style>
<script type="text/javascript" src="http://www.stashmedia.tv/wp-content/themes/default/js/superfish/superfish.js"></script>
<script type="text/javascript" src="http://www.stashmedia.tv/wp-content/themes/default/js/superfish/hoverIntent.js"></script>
<script type="text/javascript" src="http://www.stashmedia.tv/wp-content/themes/default/js/jquery.anythingslider.js"></script>
<script type="text/javascript" src="http://www.stashmedia.tv/wp-content/themes/default/js/jquery.anythingslider.video.js"></script>
<script type="text/javascript" src="http://www.stashmedia.tv/wp-content/themes/default/js/swfobject.js"></script>
<script type="text/javascript" src="http://www.stashmedia.tv/wp-content/themes/default/js/jquery.masonry.min.js"></script>

<script src="http://platform.twitter.com/widgets.js" type="text/javascript"></script>
<script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script>
<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>

<link href='http://fonts.googleapis.com/css?family=Oswald' rel='stylesheet' type='text/css'>

<script type="text/javascript"> 
	var $j = jQuery.noConflict();
	$j(document).ready(function() { 
		$j('.menu').superfish(); 
	});
</script>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-274474-3']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>

<script type="text/javascript">
	var $j = jQuery.noConflict();
	$j(function(){
		$j('#slider1').anythingSlider({
			width           : 960,
			height          : 660,
			delay           : 8000,
			resumeDelay     : 10000,
			startStopped    : false,
			autoPlay        : true,
			autoPlayLocked  : false,
			easing          : "swing"
		});
	});
</script>

<script type="text/javascript"> 
	var $j = jQuery.noConflict();
	$j(document).ready(function () {
		$j('#homeslider iframe').each(function() {
			var url = $j(this).attr("src")
			$j(this).attr("src",url+"&amp;wmode=Opaque")
		});
	});
</script>

<script type="text/javascript"> 
	var $j = jQuery.noConflict();
	$j(function(){
	  $j('#portfolio .postarea').masonry({
	    // options
	    itemSelector : '.portfolio',
	    columnWidth : 320
	  });
	});
</script>


<meta name="google-site-verification" content="ZDHx0JULblJnjKYBdlEm0Wg_mtuYI2zSRuqjZFJFzIw" />

</head>

<body class="nopad post-template-default single single-post postid-51537 single-format-standard custom-background category-cg">


    
    <link href="/css/menu.css" rel="stylesheet" type="text/css" />

    
<header id="nav">
	<div class="logo-div">
		<a href="/" class="logo-bar"><img src="/images/menu/nav/top-logo.png" alt="Stash" /></a>
		<div class="search-social">
			<form class="search-form" method="get" action="/">
				<p class="share-icons">
					<a href="https://twitter.com/stash_magazine" target="_blank" class="social-icon social-icon-twitter" title="Twitter">Twitter</a>
					<a href="https://vimeo.com/stashmedia" target="_blank" class="social-icon social-icon-vimeo" title="Vimeo">Vimeo</a>
					<a href="https://www.facebook.com/stashmag" target="_blank" class="social-icon social-icon-facebook" title="Facebook">Facebook</a>
				</p>
				<p class="search-label">
					<label for="search" >
						<input type="text" name="s" id="search" title="Search Stash" value="" />
					</label>
					<button class="search-icon" title="Search Stash"></button>
				</p>
			</form>
		</div>
	</div>
	<div class="nav-menu">
		<span class="insight-title">INSPIRATION + INSIGHT</span>
		<a href="/newtrial.php">Free Trial</a>
		<a href="/subscribe.php">Subscribe</a>
		<a href="/archive/" >The Collection</a>
		<a href="/submit/" >Submit</a>
		<a href="http://www.stashjobs.com/">Jobs</a>
		<a href="/about/">About</a>
		<div class="c-UserMenu">
			<a href="/login.php" >Login</a>

			<form action="/login.php" method="post" class="c-PopupLogin" autocomplete="off">
				<p class="c-FieldGroup c-FieldGroupShadow">
					<label for="txtemail">
						<span class="c-FieldGroupLabel">Username</span>
						<input type="text" name="txtemail" id="txtemail" value="" />
					</label>
				</p>
				<p class="c-FieldGroup c-FieldGroupShadow c-ShortenedField">
					<label for="txtPassword">
						<span class="c-FieldGroupLabel">Password</span>
						<input type="password" name="txtPassword" id="txtPassword" />
					</label>
					<a href="/forgotpw.php" class="c-ChangeField">Forgot?</a>
				</p>
				<p class="c-BtnLogin-Container">
					<button class="c-BtnLogin">Login</button>
				</p>
			</form>
		</div>
	</div>
</header>

    <script type="text/javascript" src="/js/menu.js"></script>

    
    <!-- BuySellAds Ad Code -->
    <script type="text/javascript">
    (function(){
      var bsa = document.createElement('script');
         bsa.type = 'text/javascript';
         bsa.async = true;
         bsa.src = 'http://s3.buysellads.com/ac/bsa.js';
      (document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(bsa);
    })();
    </script>
    <!-- End BuySellAds Ad Code -->

    <div id="wrap">
            <div style="clear:both;"></div><div id="container">
<div class="left_wrap">
	<div id="content" class="top">	
		
							<div class="postvid_single"><iframe width="960" height="540" src="https://www.youtube.com/embed/EAYN08YoaV8?rel=0&showinfo=0" frameborder="0" allowfullscreen></iframe></div>
			</div>

	<div id="content" class="left">	

		<div class="postarea">

			
            <div class="title_page">

				<h1>Beyond Good &#038; Evil 2: The Best Trailer of E3 2017</h1>

                <div class="postauthor">
                    <p>Posted   on Thursday, June 15, 2017 &middot; <a href="http://www.stashmedia.tv/good-evil-2-trailer/#respond">Leave a Comment</a>&nbsp;</p>
                                    </div>
            </div>

			<div class="addtoany_share_save_container addtoany_content_top"><div class="a2a_kit a2a_kit_size_16 addtoany_list" data-a2a-url="http://www.stashmedia.tv/good-evil-2-trailer/" data-a2a-title="Beyond Good & Evil 2: The Best Trailer of E3 2017"><a class="a2a_button_facebook" href="http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F&amp;linkname=Beyond%20Good%20%26%20Evil%202%3A%20The%20Best%20Trailer%20of%20E3%202017" title="Facebook" rel="nofollow" target="_blank"></a><a class="a2a_button_twitter" href="http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F&amp;linkname=Beyond%20Good%20%26%20Evil%202%3A%20The%20Best%20Trailer%20of%20E3%202017" title="Twitter" rel="nofollow" target="_blank"></a><a class="a2a_button_pinterest" href="http://www.addtoany.com/add_to/pinterest?linkurl=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F&amp;linkname=Beyond%20Good%20%26%20Evil%202%3A%20The%20Best%20Trailer%20of%20E3%202017" title="Pinterest" rel="nofollow" target="_blank"></a><a class="a2a_button_tumblr" href="http://www.addtoany.com/add_to/tumblr?linkurl=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F&amp;linkname=Beyond%20Good%20%26%20Evil%202%3A%20The%20Best%20Trailer%20of%20E3%202017" title="Tumblr" rel="nofollow" target="_blank"></a><a class="a2a_button_google_plus" href="http://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F&amp;linkname=Beyond%20Good%20%26%20Evil%202%3A%20The%20Best%20Trailer%20of%20E3%202017" title="Google+" rel="nofollow" target="_blank"></a><a class="a2a_button_reddit" href="http://www.addtoany.com/add_to/reddit?linkurl=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F&amp;linkname=Beyond%20Good%20%26%20Evil%202%3A%20The%20Best%20Trailer%20of%20E3%202017" title="Reddit" rel="nofollow" target="_blank"></a><a class="a2a_button_whatsapp" href="http://www.addtoany.com/add_to/whatsapp?linkurl=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F&amp;linkname=Beyond%20Good%20%26%20Evil%202%3A%20The%20Best%20Trailer%20of%20E3%202017" title="WhatsApp" rel="nofollow" target="_blank"></a><a class="a2a_button_facebook_messenger" href="http://www.addtoany.com/add_to/facebook_messenger?linkurl=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F&amp;linkname=Beyond%20Good%20%26%20Evil%202%3A%20The%20Best%20Trailer%20of%20E3%202017" title="Facebook Messenger" rel="nofollow" target="_blank"></a><a class="a2a_button_sms" href="http://www.addtoany.com/add_to/sms?linkurl=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F&amp;linkname=Beyond%20Good%20%26%20Evil%202%3A%20The%20Best%20Trailer%20of%20E3%202017" title="SMS" rel="nofollow" target="_blank"></a><a class="a2a_button_email" href="http://www.addtoany.com/add_to/email?linkurl=http%3A%2F%2Fwww.stashmedia.tv%2Fgood-evil-2-trailer%2F&amp;linkname=Beyond%20Good%20%26%20Evil%202%3A%20The%20Best%20Trailer%20of%20E3%202017" title="Email" rel="nofollow" target="_blank"></a></div></div><p>Fourteen years after the original game, the follow up to Ubisoft&#8217;s Beyond Good &#038; Evil (actually a prequel) made a surprise appearance at E3 2017 with this potty-mouthed but raucous and richly detailed clip.</p>
<p>Not much is known about the update, including the release date, but according to the game&#8217;s Facebook page Ubisoft is &#8220;delighted to confirm that Michel Ancel is currently working with the Ubisoft Montpellier studio on a new Beyond Good &#038; Evil game featuring a massive, seamless online environment.&#8221;</p>
<p><img src="http://www.stashmedia.tv/wp-content/uploads/2017-06-15_0626-640x273.png" alt="Ubisoft Beyond good and evel 2 | STASH MAGAZINE" width="640" height="273" class="alignnone size-large wp-image-51548" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-06-15_0626-640x273.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-06-15_0626-768x327.png 768w, http://www.stashmedia.tv/wp-content/uploads/2017-06-15_0626-300x128.png 300w, http://www.stashmedia.tv/wp-content/uploads/2017-06-15_0626.png 1436w" sizes="(max-width: 640px) 100vw, 640px" /></p>
<p><img src="http://www.stashmedia.tv/wp-content/uploads/2017-06-15_06291-640x272.png" alt="Ubisoft Beyond good and evel 2 | STASH MAGAZINE" width="640" height="272" class="alignnone size-large wp-image-51551" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-06-15_06291-640x272.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-06-15_06291-768x326.png 768w, http://www.stashmedia.tv/wp-content/uploads/2017-06-15_06291-300x127.png 300w, http://www.stashmedia.tv/wp-content/uploads/2017-06-15_06291.png 1435w" sizes="(max-width: 640px) 100vw, 640px" /></p>
<p><img src="http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0818-640x272.png" alt="Ubisoft Beyond good and evel 2 | STASH MAGAZINE" width="640" height="272" class="alignnone size-large wp-image-51544" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0818-640x272.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0818-768x327.png 768w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0818-300x128.png 300w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0818.png 1437w" sizes="(max-width: 640px) 100vw, 640px" /></p>
<p><img src="http://www.stashmedia.tv/wp-content/uploads/2017-06-15_0620-640x271.png" alt="Ubisoft Beyond good and evel 2 | STASH MAGAZINE" width="640" height="271" class="alignnone size-large wp-image-51545" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-06-15_0620-640x271.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-06-15_0620-768x325.png 768w, http://www.stashmedia.tv/wp-content/uploads/2017-06-15_0620-300x127.png 300w, http://www.stashmedia.tv/wp-content/uploads/2017-06-15_0620.png 1436w" sizes="(max-width: 640px) 100vw, 640px" /></p>
<p><img src="http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0815-640x272.png" alt="Ubisoft Beyond good and evel 2 | STASH MAGAZINE" width="640" height="272" class="alignnone size-large wp-image-51541" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0815-640x272.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0815-768x326.png 768w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0815-300x127.png 300w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0815.png 1435w" sizes="(max-width: 640px) 100vw, 640px" /></p>
<p><img src="http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0816-640x272.png" alt="Ubisoft Beyond good and evel 2 | STASH MAGAZINE" width="640" height="272" class="alignnone size-large wp-image-51542" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0816-640x272.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0816-768x326.png 768w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0816-300x127.png 300w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0816.png 1436w" sizes="(max-width: 640px) 100vw, 640px" /></p>
<p><img src="http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0817-640x272.png" alt="Ubisoft Beyond good and evel 2 | STASH MAGAZINE" width="640" height="272" class="alignnone size-large wp-image-51543" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0817-640x272.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0817-768x326.png 768w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0817-300x127.png 300w, http://www.stashmedia.tv/wp-content/uploads/2017-06-14_0817.png 1438w" sizes="(max-width: 640px) 100vw, 640px" /></p>
<p>Publisher: Ubisoft<br />
Creator: Michel Ancel<br />
Production: Ubisoft Montpellier</p>

									
			<div style="clear:both;"></div>
			<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://www.stashmedia.tv/good-evil-2-trailer/"
    dc:identifier="http://www.stashmedia.tv/good-evil-2-trailer/"
    dc:title="Beyond Good &#038; Evil 2: The Best Trailer of E3 2017"
    trackback:ping="http://www.stashmedia.tv/good-evil-2-trailer/trackback/" />
</rdf:RDF>
			<div class="postmeta">
				<p>Category: <a href="http://www.stashmedia.tv/category/feed/cg/" rel="category tag">CG</a>, <a href="http://www.stashmedia.tv/category/feed/character-animation/" rel="category tag">Character Animation</a>, <a href="http://www.stashmedia.tv/category/featured/" rel="category tag">Featured</a>, <a href="http://www.stashmedia.tv/category/feed/games/" rel="category tag">Games</a> &middot; Tags: <a href="http://www.stashmedia.tv/tag/beyond-good-evil/" rel="tag">Beyond Good &amp; Evil</a>, <a href="http://www.stashmedia.tv/tag/michel-ancel/" rel="tag">Michel Ancel</a>, <a href="http://www.stashmedia.tv/tag/ubisoft/" rel="tag">Ubisoft</a></p>
			</div>

		</div>

		<div class="related-posts" style="padding-top:0px;"><h3 style="font-size:1.2em;">You may also like:</h3><div class="related-posts-list"><div clas="related-post" style="width:31%;display:inline-block;vertical-align:top;margin-right:2%;margin-bottom:20px;"><a href="/oscar-winner-daniel-greaves-mr-plastimime-kickstarter"><img src="http://www.stashmedia.tv/wp-content/uploads/2013/04/432184382_640.jpg" alt="Oscar-winner Daniel Greaves' "Mr. Plastimime" on Kickstarter " class="related-post-image" style="width:100%;height:auto;display:block;" /></a><h3 style="padding-top:8px;"><a href="/oscar-winner-daniel-greaves-mr-plastimime-kickstarter" style="font-family:Robotolight;font-weight:lighter;font-size:16px;text-transform:none;">Oscar-winner Daniel Greaves' "Mr. Plastimime" on Kickstarter </a></h3></div><div clas="related-post" style="width:31%;display:inline-block;vertical-align:top;margin-right:2%;margin-bottom:20px;"><a href="/franck-dion-monsieur-cok"><img src="http://www.stashmedia.tv/wp-content/uploads/2014/03/Dion_Monsieur-COK3-640x360.png" alt="Franck Dion "Monsieur COK"" class="related-post-image" style="width:100%;height:auto;display:block;" /></a><h3 style="padding-top:8px;"><a href="/franck-dion-monsieur-cok" style="font-family:Robotolight;font-weight:lighter;font-size:16px;text-transform:none;">Franck Dion "Monsieur COK"</a></h3></div><div clas="related-post" style="width:31%;display:inline-block;vertical-align:top;margin-right:2%;margin-bottom:20px;"><a href="/satellites-wasteland-m-i-e"><img src="http://www.stashmedia.tv/wp-content/uploads/2013/07/MIE_Satellites-640x360.png" alt="M-I-E Cruises "Wasteland" with the Satellites" class="related-post-image" style="width:100%;height:auto;display:block;" /></a><h3 style="padding-top:8px;"><a href="/satellites-wasteland-m-i-e" style="font-family:Robotolight;font-weight:lighter;font-size:16px;text-transform:none;">M-I-E Cruises "Wasteland" with the Satellites</a></h3></div><div clas="related-post" style="width:31%;display:inline-block;vertical-align:top;margin-right:2%;margin-bottom:20px;"><a href="/80s-flashback-buck-ny"><img src="http://www.stashmedia.tv/wp-content/uploads/2013/04/buck_80s-640x358.jpg" alt="80's Flashback From Buck NY " class="related-post-image" style="width:100%;height:auto;display:block;" /></a><h3 style="padding-top:8px;"><a href="/80s-flashback-buck-ny" style="font-family:Robotolight;font-weight:lighter;font-size:16px;text-transform:none;">80's Flashback From Buck NY </a></h3></div><div clas="related-post" style="width:31%;display:inline-block;vertical-align:top;margin-right:2%;margin-bottom:20px;"><a href="/3-d-printed-fibonacci-zoetrope-sculptures"><img src="http://www.stashmedia.tv/wp-content/uploads/2015/01/Edlund_Fibonnaci-Zoetrope-sculptures-640x360.png" alt="3-D Printed Fibonacci Zoetrope Sculptures" class="related-post-image" style="width:100%;height:auto;display:block;" /></a><h3 style="padding-top:8px;"><a href="/3-d-printed-fibonacci-zoetrope-sculptures" style="font-family:Robotolight;font-weight:lighter;font-size:16px;text-transform:none;">3-D Printed Fibonacci Zoetrope Sculptures</a></h3></div><div clas="related-post" style="width:31%;display:inline-block;vertical-align:top;margin-right:2%;margin-bottom:20px;"><a href="/anne-cbcs-timeless-canadian-girl"><img src="http://www.stashmedia.tv/wp-content/uploads/IF_CBC-Anne-640x360.png" alt="Anne: The CBC's Timeless Canadian Girl?" class="related-post-image" style="width:100%;height:auto;display:block;" /></a><h3 style="padding-top:8px;"><a href="/anne-cbcs-timeless-canadian-girl" style="font-family:Robotolight;font-weight:lighter;font-size:16px;text-transform:none;">Anne: The CBC's Timeless Canadian Girl?</a></h3></div></div></div>
        <div class="postcomments">
			
<!-- You can start editing here. -->

	
			<!-- If comments are open, but there are no comments. -->

	 


<div id="respond">

<h5>Leave A Comment</h5>

<div class="cancel-comment-reply">
	<small><a rel="nofollow" id="cancel-comment-reply-link" href="/good-evil-2-trailer/#respond" style="display:none;">Click here to cancel reply.</a></small>
</div>


<form action="http://www.stashmedia.tv/wp-comments-post.php" method="post" id="commentform">


<p><input type="text" name="author" id="author" value="" size="22" tabindex="1" aria-required='true' />
<label for="author" style="font-size:15px;">Name (required)</label></p>

<p><input type="text" name="email" id="email" value="" size="22" tabindex="2" aria-required='true' />
<label for="email" style="font-size:15px;">Email (will not be published) (required)</label></p>

<!-- <p><input type="text" name="url" id="url" value="" size="22" tabindex="3" />
<label for="url"><small>Website</small></label></p> -->


<!--<p><small><strong>XHTML:</strong> You can use these tags: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </code></small></p>-->

<p><textarea name="comment" id="comment" cols="100%" rows="10" tabindex="4"></textarea></p>

<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" style="margin-right:20px;" />
<span style="position:relative;top:2px;"><input type='hidden' name='comment_post_ID' value='51537' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</span>
</p>
<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ff1b9f676c" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_mad_mimi" id="subscribe_mad_mimi" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_mad_mimi">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="44"/></p>
</form>
</div>


        </div>

		
	</div>
</div>




<div id="sidebar_right_home">
	<div id="text-13" class="widget-1 widget-first widget-odd widget widget_text">			<div class="textwidget"><a href="https://www.animago.com/en//" target="_blank">
<img src="http://www.stashmedia.tv/wp-content/uploads/animago2017_Banner_300x600px-2.gif" />
</a></div>
		</div><div id="text-10" class="widget-2 widget-even widget widget_text">			<div class="textwidget"><a href="https://www.audioblocks.com/join/offer?utm_v=2&utm_source=StashMedia&utm_medium=publication&utm_campaign=AB-display---99&campaign_date=2017-06-01&utm_content=---ABBold300x600" target="_blank" style="display:block;margin-top:20px;">
<img src="http://www.stashmedia.tv/wp-content/uploads/300x600-abvibrantbg-createwithus-tryfree7days.png" />
</a></div>
		</div><div id="text-11" class="widget-3 widget-odd widget widget_text">			<div class="textwidget"><!-- start feedwind code --> <script type="text/javascript" src="https://feed.mikle.com/js/fw-loader.js" data-fw-param="?widget_parameter=%7B%22sources%22%3A%5B%7B%22source%22%3A%22http%3A%2F%2Fwww.stashjobs.com%22%2C%22type%22%3A%22RSS%22%7D%5D%2C%22name%22%3A%22%22%2C%22width%22%3A0%2C%22height%22%3A0%2C%22height_by_article%22%3A%223%22%2C%22target%22%3A%22_blank%22%2C%22font%22%3A%22Arial%2C%20Helvetica%2C%20sans-serif%22%2C%22title_font_size%22%3A%2216%22%2C%22item_title_font_size%22%3A%2214%22%2C%22item_description_font_size%22%3A%2212%22%2C%22border%22%3A%22on%22%2C%22css_url%22%3A%22%22%2C%22responsive%22%3A%22on%22%2C%22text_direction%22%3A%22left%22%2C%22text_alignment%22%3A%22left%22%2C%22corner%22%3A%22rounded%22%2C%22scroll%22%3A%22on%22%2C%22auto_scroll%22%3A%22on%22%2C%22auto_scroll_direction%22%3A%22up%22%2C%22auto_scroll_step_speed%22%3A%224%22%2C%22auto_scroll_mc_speed%22%3A%2220%22%2C%22sort%22%3A%22off%22%2C%22title%22%3A%22on%22%2C%22title_sentence%22%3A%22STASHJOBS%22%2C%22title_link%22%3A%22http%3A%2F%2Fwww.stashjobs.com%2F%22%2C%22title_bgcolor%22%3A%22%23ffffff%22%2C%22title_color%22%3A%22%23505659%22%2C%22title_bgimage%22%3A%22%22%2C%22item_bgcolor%22%3A%22%23ffffff%22%2C%22item_bgimage%22%3A%22%22%2C%22item_title_length%22%3A%22100%22%2C%22item_title_color%22%3A%22%2376787a%22%2C%22item_border_bottom%22%3A%22on%22%2C%22item_description%22%3A%22title_only%22%2C%22item_link%22%3A%22on%22%2C%22item_description_length%22%3A%22100%22%2C%22item_description_color%22%3A%22%23505659%22%2C%22item_date%22%3A%22on%22%2C%22item_date_format%22%3A%22%25e.%25m.%25Y%20%25k%3A%25M%22%2C%22item_date_timezone%22%3A%22%22%2C%22item_description_style%22%3A%22thumbnail%22%2C%22item_thumbnail%22%3A%22full%22%2C%22item_thumbnail_selection%22%3A%22auto%22%2C%22article_num%22%3A%2250%22%2C%22item_player%22%3A%22off%22%2C%22keyword_inc%22%3A%22%22%2C%22keyword_exc%22%3A%22%22%7D"></script> <!-- end feedwind code --></div>
		</div><div id="postsfromcategorywidget-3" class="widget-4 widget-even widget widget_postsfromcategorywidget"><h4>The Inbox</h4><div class="post-cat-widget"><div class="category-6 post size-medium odd"><div class="post-thumb"><a href="http://www.stashmedia.tv/alma-mater-welcomes-executive-producer-ben-apley-director-ronnie-koff/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/Alma-Mater-640x360.png" class="attachment-medium size-medium wp-post-image" alt="Ben Apley Ronnie Koff | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/Alma-Mater.png 640w, http://www.stashmedia.tv/wp-content/uploads/Alma-Mater-300x169.png 300w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/alma-mater-welcomes-executive-producer-ben-apley-director-ronnie-koff/"><BR>Alma Mater Welcomes EP Ben Apley and Director Ronnie Koff</a></h3></div></div><div class="category-6 post size-medium even"><div class="post-thumb"><a href="http://www.stashmedia.tv/alkemy-expands-vfx-team-hires/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/Alchemy-640x360.png" class="attachment-medium size-medium wp-post-image" alt="Alchemy X | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/Alchemy.png 640w, http://www.stashmedia.tv/wp-content/uploads/Alchemy-300x169.png 300w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/alkemy-expands-vfx-team-hires/"><BR>Alkemy X Expands VFX Team With New Hires</a></h3></div></div><div class="category-6 post size-medium odd"><div class="post-thumb"><a href="http://www.stashmedia.tv/quietman-signs-director-nico-beyer/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/Nico-Beyer_Quietman-640x360.png" class="attachment-medium size-medium wp-post-image" alt="Nico Beyer_director| STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/Nico-Beyer_Quietman-640x360.png 640w, http://www.stashmedia.tv/wp-content/uploads/Nico-Beyer_Quietman-768x432.png 768w, http://www.stashmedia.tv/wp-content/uploads/Nico-Beyer_Quietman-300x169.png 300w, http://www.stashmedia.tv/wp-content/uploads/Nico-Beyer_Quietman.png 861w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/quietman-signs-director-nico-beyer/"><BR>Quietman Signs Director Nico Beyer</a></h3></div></div><div class="category-6 post size-medium even"><div class="post-thumb"><a href="http://www.stashmedia.tv/elastic-welcomes-luke-colson-role-executive-producer/"><img width="640" height="361" src="http://www.stashmedia.tv/wp-content/uploads/Luke-Colson-Elastic-640x361.png" class="attachment-medium size-medium wp-post-image" alt="Luke Colson | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/Luke-Colson-Elastic-640x360.png 640w, http://www.stashmedia.tv/wp-content/uploads/Luke-Colson-Elastic-768x433.png 768w, http://www.stashmedia.tv/wp-content/uploads/Luke-Colson-Elastic-300x169.png 300w, http://www.stashmedia.tv/wp-content/uploads/Luke-Colson-Elastic.png 852w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/elastic-welcomes-luke-colson-role-executive-producer/"><BR>Elastic Welcomes Luke Colson in the Role of Executive Producer</a></h3></div></div><div class="category-6 post size-medium odd"><div class="post-thumb"><a href="http://www.stashmedia.tv/vfx-veterans-john-hughes-helena-packer-launch-phd-director-kevin-donovan/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/PHD-640x360.png" class="attachment-medium size-medium wp-post-image" alt="John Hughes PHD | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/PHD-640x360.png 640w, http://www.stashmedia.tv/wp-content/uploads/PHD-768x432.png 768w, http://www.stashmedia.tv/wp-content/uploads/PHD-300x169.png 300w, http://www.stashmedia.tv/wp-content/uploads/PHD.png 866w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/vfx-veterans-john-hughes-helena-packer-launch-phd-director-kevin-donovan/"><BR>VFX veterans John Hughes and Helena Packer Launch PHD with director Kevin Donovan</a></h3></div></div><div class="category-6 post size-medium even"><div class="post-thumb"><a href="http://www.stashmedia.tv/the-artery-names-liron-ashkenazi-eldar-lead-design-director/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/Liron-Ashkenazi-Eldar-Artery-640x360.png" class="attachment-medium size-medium wp-post-image" alt="Liron Ashkenazi-Eldar Design director" srcset="http://www.stashmedia.tv/wp-content/uploads/Liron-Ashkenazi-Eldar-Artery.png 640w, http://www.stashmedia.tv/wp-content/uploads/Liron-Ashkenazi-Eldar-Artery-300x169.png 300w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/the-artery-names-liron-ashkenazi-eldar-lead-design-director/"><BR>The-Artery names Liron Ashkenazi-Eldar as Lead Design Director</a></h3></div></div><div class="category-6 post size-medium odd"><div class="post-thumb"><a href="http://www.stashmedia.tv/bill-galusha-joins-leviathan-senior-producer/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/2017-05-26_0833-640x360.png" class="attachment-medium size-medium wp-post-image" alt="Bill Galusha | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-05-26_0833.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-05-26_0833-300x169.png 300w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/bill-galusha-joins-leviathan-senior-producer/"><BR>Bill Galusha Joins Leviathan as Senior Producer</a></h3></div></div><div class="category-6 post size-medium even"><div class="post-thumb"><a href="http://www.stashmedia.tv/gabriel-portnof-joins-framestore-cg-supervisor/"><img width="640" height="361" src="http://www.stashmedia.tv/wp-content/uploads/2017-05-25_1609-640x361.png" class="attachment-medium size-medium wp-post-image" alt="Gabriel Portnof Framestore | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-05-25_1609-640x360.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-05-25_1609-300x169.png 300w, http://www.stashmedia.tv/wp-content/uploads/2017-05-25_1609.png 738w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/gabriel-portnof-joins-framestore-cg-supervisor/"><BR>Gabriel Portnof joins Framestore NY as CG Supervisor</a></h3></div></div><div class="category-6 post size-medium odd"><div class="post-thumb"><a href="http://www.stashmedia.tv/jordi-bares-joins-framestore-creative-director/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/Jordi-Barnes-Framestore-640x360.png" class="attachment-medium size-medium wp-post-image" alt="Jordi Barnes Framestore | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/Jordi-Barnes-Framestore-640x360.png 640w, http://www.stashmedia.tv/wp-content/uploads/Jordi-Barnes-Framestore-300x169.png 300w, http://www.stashmedia.tv/wp-content/uploads/Jordi-Barnes-Framestore.png 745w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/jordi-bares-joins-framestore-creative-director/"><BR>Jordi Bares Joins Framestore as Creative Director</a></h3></div></div><div class="category-6 post size-medium even"><div class="post-thumb"><a href="http://www.stashmedia.tv/logan-adds-paul-abatemarco-ep-los-angeles/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/Paul-Abatemarco-Logan-640x360.png" class="attachment-medium size-medium wp-post-image" alt="Paul-Abatemarco Logan | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/Paul-Abatemarco-Logan-640x360.png 640w, http://www.stashmedia.tv/wp-content/uploads/Paul-Abatemarco-Logan-300x169.png 300w, http://www.stashmedia.tv/wp-content/uploads/Paul-Abatemarco-Logan.png 747w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/logan-adds-paul-abatemarco-ep-los-angeles/"><BR>LOGAN Adds Paul Abatemarco as EP in Los Angeles</a></h3></div></div><div class="category-6 post size-medium odd"><div class="post-thumb"><a href="http://www.stashmedia.tv/la-studio-roygbiv-signs-passion-animation-studios/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/2017-05-19_0738-640x360.png" class="attachment-medium size-medium wp-post-image" alt="ROYGBIV | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-05-19_0738-640x360.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-05-19_0738-768x432.png 768w, http://www.stashmedia.tv/wp-content/uploads/2017-05-19_0738-300x169.png 300w, http://www.stashmedia.tv/wp-content/uploads/2017-05-19_0738.png 960w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/la-studio-roygbiv-signs-passion-animation-studios/"><BR>LA Studio ROYGBIV Signs to Passion Animation Studios</a></h3></div></div><div class="category-6 post size-medium even"><div class="post-thumb"><a href="http://www.stashmedia.tv/evil-presents-feed-light-june-6th/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/SNE-640x360.jpg" class="attachment-medium size-medium wp-post-image" alt="SNE Feed Me Light | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/SNE.jpg 640w, http://www.stashmedia.tv/wp-content/uploads/SNE-300x169.jpg 300w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/evil-presents-feed-light-june-6th/"><BR>See No Evil Presents Feed Me Light, June 6th</a></h3></div></div><div class="category-6 post size-medium odd"><div class="post-thumb"><a href="http://www.stashmedia.tv/strangelove-signs-eugen-merher/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/2017-05-10_0811-640x360.png" class="attachment-medium size-medium wp-post-image" alt="Director EUGEN MERHER | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-05-10_0811.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-05-10_0811-300x169.png 300w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/strangelove-signs-eugen-merher/"><BR>STRANGELOVE SIGNS EUGEN MERHER</a></h3></div></div><div class="category-6 post size-medium even"><div class="post-thumb"><a href="http://www.stashmedia.tv/assembly-welcomes-executive-producer-oritte-bendory/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/2017-05-05_0920-640x360.png" class="attachment-medium size-medium wp-post-image" alt="Oritte Bendory | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/2017-05-05_0920-640x360.png 640w, http://www.stashmedia.tv/wp-content/uploads/2017-05-05_0920-300x169.png 300w, http://www.stashmedia.tv/wp-content/uploads/2017-05-05_0920.png 749w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/assembly-welcomes-executive-producer-oritte-bendory/"><BR>Assembly Welcomes Executive Producer Oritte Bendory</a></h3></div></div><div class="category-6 post size-medium odd"><div class="post-thumb"><a href="http://www.stashmedia.tv/animation-director-daniel-gray-joins-nomint/"><img width="640" height="360" src="http://www.stashmedia.tv/wp-content/uploads/Daniel-Gray-640x360.png" class="attachment-medium size-medium wp-post-image" alt="Daniel Gray animation | STASH MAGAZINE" srcset="http://www.stashmedia.tv/wp-content/uploads/Daniel-Gray-640x360.png 640w, http://www.stashmedia.tv/wp-content/uploads/Daniel-Gray-768x432.png 768w, http://www.stashmedia.tv/wp-content/uploads/Daniel-Gray-300x169.png 300w, http://www.stashmedia.tv/wp-content/uploads/Daniel-Gray.png 930w" sizes="(max-width: 640px) 100vw, 640px" /></a></div><div class="post-content"><h3 class="post-title"><a href="http://www.stashmedia.tv/animation-director-daniel-gray-joins-nomint/"><BR>Animation Director Daniel Gray Joins NOMINT</a></h3></div></div></div></div><div id="text-9" class="widget-5 widget-last widget-odd widget widget_text">			<div class="textwidget"></div>
		</div></div>
</div>

		<div style="clear:both;"></div>

		<div id="footertopbg">
			<div id="footerwidgets">
				<div class="footerwidgetleft">
														</div>
				<div class="footerwidgetmidleft">
														</div>
				<div class="footerwidgetmidright">
														</div>
				<div class="footerwidgetright">
					<div id="text-8" class="widget-1 widget-first widget-last widget-odd widget widget_text">			<div class="textwidget"></div>
		</div>				</div>
			</div>
		</div>

<!-- <div id="footerbg">
	<div id="footer">
		<div class="footeright">
			<div class="footertop">
				<p><a href="http://www.stashmedia.tv/contact/">CONTACT</a>&nbsp;&nbsp;&nbsp; <a href="http://www.stashmedia.tv/about/">ABOUT</a></p>
			</div>
			<div class="footerleft">
				<div class="footertop">
					<p>Copyright 2017 STASH &middot; <a href="http://www.stashmedia.tv/feed/rss/" target="_blank">RSS Feed</a> &middot; <a href="http://www.stashmedia.tv/wp-login.php">Log in</a></p>
				</div>
				<div class="footerbottom"></div>
			</div>
			<div class="footerright"></div>
		</div>
	</div>
</div> -->


		<footer class="c-Footer" style="margin:0;">
			<nav class="c-Footer-Nav">
				<a href="/submit/">SUBMIT</a>
				<a href="/about/">ABOUT</a>
				<a href="/contact/">CONTACT</a>
			</nav>
			<p class="c-Copyright">Copyright &copy; 2017 Stash Media, Inc.</p>
		</footer>

				<script src="https://d3nwz0jnsb9ayz.cloudfront.net/publisherscript_min.js"></script>
		<script>{publisher_id='752b8ff8-9775-4234-96d3-626b015800b0';}</script>
	</body>
</html>